meta-bbb: Switch branch sumo -> thud

Signed-off-by: Thomas Klaehn <thomas.klaehn@u-blox.com>
This commit is contained in:
Thomas Klaehn 2019-01-25 15:17:44 +01:00
parent 696eefc352
commit 2fbd72bf71
18 changed files with 7 additions and 305 deletions

View File

@ -12,5 +12,6 @@ BBLAYERS ?= " \
${TOPDIR}/../layers/meta-openembedded/meta-oe \
${TOPDIR}/../layers/meta-openembedded/meta-networking \
${TOPDIR}/../layers/meta-openembedded/meta-python \
${TOPDIR}/../layers/meta-blackfinn \
${TOPDIR}/../layers/meta-bbb \
"

View File

@ -35,10 +35,6 @@ CONF_VERSION = "1"
INHERIT += "rm_work"
INHERIT += "icecc"
ICECC_PATH = "/usr/bin/icecc"
ICECC_PARALLEL_MAKE = "-j 20"
INHERIT += "own-mirrors"
SOURCE_MIRROR_URL = "https://files.blackfinn.de/mirror/sources"
BB_GENERATE_MIRROR_TARBALLS = "1"

View File

@ -1,15 +0,0 @@
require conf/distro/poky.conf
# distro name
DISTRO = "tkl"
DISTRO_NAME = "tkl distribution"
DISTRO_VERSION = "1.0"
DISTRO_CODENAME = "tkl"
#DISTRO_FEATURES_append = " alsa usbhost usbgadget keyboard bluetooth"
PREFERRED_VERSION_mypy = "0.4.2"
SDK_VENDOR = "-tkldistsdk"
SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
MAINTAINER = "tkldist "
INHERIT += "buildhistory"
BUILDHISTORY_COMMIT = "1"

View File

@ -4,16 +4,12 @@ BBPATH .= ":${LAYERDIR}"
# We have recipes-* directories, add to BBFILES
BBFILES += " \
${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/images/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend \
"
PREFERRED_VERSION_pypio ?= "1.0.0"
PREFERRED_VERSION_pywm ?= "1.0.0"
PREFERRED_VERSION_ultrasonic-distance ?= "1.1.0"
BBFILE_COLLECTIONS += "meta-bbb"
BBFILE_PATTERN_meta-bbb = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-bbb = "7"
LAYERSERIES_COMPAT_meta-bbb = "sumo rocko"
LAYERSERIES_COMPAT_meta-bbb = "thud sumo rocko"

View File

@ -1,99 +0,0 @@
SUMMARY = "A console image with some additional tools"
HOMEPAGE = "https://blackfinn.de"
LICENSE = "MIT"
inherit core-image extrausers
IMAGE_FEATURES += "package-management"
# Encrypt the password with: echo "<password>" | openssl passwd -1 -stdin
EXTRA_USERS_PARAMS = " \
usermod -p '\$1\$4h5Qdc3i\$Vke4J2Ci5z.D3TtFDmV9r/' root; \
useradd -p '\$1\$4h5Qdc3i\$Vke4J2Ci5z.D3TtFDmV9r/' tkl; \
"
CORE_OS = " \
openssh \
openssh-keygen \
openssh-sftp-server \
psplash \
tzdata \
"
KERNEL_EXTRA_INSTALL = " \
kernel-modules \
"
WIFI_SUPPORT = " \
iw \
linux-firmware-rtl8192cu \
wireless-tools \
wpa-supplicant \
"
DEV_SDK_INSTALL = " \
file \
git \
make \
perl-modules \
pkgconfig \
python-modules \
"
EXTRA_TOOLS_INSTALL = " \
acpid \
bc \
bzip2 \
dosfstools \
e2fsprogs-mke2fs \
ethtool \
findutils \
htop \
i2c-tools \
less \
mc \
procps \
rsync \
sysfsutils \
unzip \
util-linux \
util-linux-blkid \
vim \
wget \
curl \
zip \
ntp \
"
MQTT = " \
python-paho-mqtt \
"
PYTHON_LIBS = " \
"
IMAGE_INSTALL += " \
${CORE_OS} \
${DEV_SDK_INSTALL} \
${EXTRA_TOOLS_INSTALL} \
${KERNEL_EXTRA_INSTALL} \
${WIFI_SUPPORT} \
${MQTT} \
${PYTHON_LIBS} \
"
set_local_timezone() {
ln -sf /usr/share/zoneinfo/Etc/UTC ${IMAGE_ROOTFS}/etc/localtime
}
disable_bootlogd() {
echo BOOTLOGD_ENABLE=no > ${IMAGE_ROOTFS}/etc/default/bootlogd
}
ROOTFS_POSTPROCESS_COMMAND += " \
set_local_timezone ; \
disable_bootlogd ; \
"
export IMAGE_BASENAME = "console-image"

View File

@ -1,17 +0,0 @@
#create encrypted passphrase with: wpa_passphrase '<ssid>' '<decrypted_key>'
country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant
update_config=1
network={
ssid="FRITZ!Box 7330_EXT"
psk=6bee2296d336ab07a1aca9f210be55095896e740225d920c0d7f15906dc35846
id_str="home_outdoor"
priority=1
}
network={
ssid="FRITZ!Box 7330"
psk=44df1640e42b8f4e4b424a39af700c817bc2b89f13c324d29c10bf7ba3028258
id_str="home_indoor"
priority=2
}

View File

@ -1,6 +0,0 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
do_install_append () {
install -m 0644 ${WORKDIR}/wpa_supplicant.conf ${D}${sysconfdir}/wpa_supplicant.conf
}

View File

@ -24,9 +24,9 @@
# Offline mode (for use in constructing flash images offline)
#option offline_root target
src/gz all https://opkg.blackfinn.de/sumo/all
src/gz beaglebone https://opkg.blackfinn.de/sumo/beaglebone
src/gz cortexa8hf-neon https://opkg.blackfinn.de/sumo/cortexa8hf-neon
src/gz all https://opkg.blackfinn.de/thud/all
src/gz beaglebone https://opkg.blackfinn.de/thud/beaglebone
src/gz cortexa8hf-neon https://opkg.blackfinn.de/thud/cortexa8hf-neon
# Default destination for installed packages
dest root /

View File

@ -1,45 +0,0 @@
diff --git a/arch/arm/boot/dts/am335x-boneblack.dts b/arch/arm/boot/dts/am335x-boneblack.dts
index db00d8ef7b19..9a5f612101db 100644
--- a/arch/arm/boot/dts/am335x-boneblack.dts
+++ b/arch/arm/boot/dts/am335x-boneblack.dts
@@ -75,6 +75,40 @@
AM33XX_IOPAD(0x86c, PIN_OUTPUT_PULLDOWN | MUX_MODE7) /* gpmc_a11.GPIO1_27 */
>;
};
+
+ ehrpwm1_pins: pinmux_ehrpwm1a_pins {
+ pinctrl-single,pins = <
+ AM33XX_IOPAD(0x848, PIN_OUTPUT | MUX_MODE6) /* gpmc_a2.ehrpwm1a */
+ AM33XX_IOPAD(0x84c, PIN_OUTPUT | MUX_MODE6) /* gpmc_a3.ehrpwm1b */
+ >;
+ };
+
+ ehrpwm2_pins: pinmux_ehrpwm2a_pins {
+ pinctrl-single,pins = <
+ AM33XX_IOPAD(0x820, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2a */
+ AM33XX_IOPAD(0x824, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2b */
+ >;
+ };
+};
+
+&epwmss1 {
+ status = "okay";
+};
+
+&epwmss2 {
+ status = "okay";
+};
+
+&ehrpwm1 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&ehrpwm1_pins>;
+};
+
+&ehrpwm2 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&ehrpwm2_pins>;
};
&lcdc {

View File

@ -1,45 +0,0 @@
diff --git a/arch/arm/boot/dts/am335x-boneblack-common.dtsi b/arch/arm/boot/dts/am335x-boneblack-common.dtsi
index 325daae40278..bd91b201bbf8 100644
--- a/arch/arm/boot/dts/am335x-boneblack-common.dtsi
+++ b/arch/arm/boot/dts/am335x-boneblack-common.dtsi
@@ -68,6 +68,40 @@
AM33XX_IOPAD(0x86c, PIN_OUTPUT_PULLDOWN | MUX_MODE7) /* gpmc_a11.GPIO1_27 */
>;
};
+
+ ehrpwm1_pins: pinmux_ehrpwm1a_pins {
+ pinctrl-single,pins = <
+ AM33XX_IOPAD(0x848, PIN_OUTPUT | MUX_MODE6) /* gpmc_a2.ehrpwm1a */
+ AM33XX_IOPAD(0x84c, PIN_OUTPUT | MUX_MODE6) /* gpmc_a3.ehrpwm1b */
+ >;
+ };
+
+ ehrpwm2_pins: pinmux_ehrpwm2a_pins {
+ pinctrl-single,pins = <
+ AM33XX_IOPAD(0x820, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2a */
+ AM33XX_IOPAD(0x824, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2b */
+ >;
+ };
+};
+
+&epwmss1 {
+ status = "okay";
+};
+
+&epwmss2 {
+ status = "okay";
+};
+
+&ehrpwm1 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&ehrpwm1_pins>;
+};
+
+&ehrpwm2 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&ehrpwm2_pins>;
};
&lcdc {

View File

@ -9,5 +9,4 @@ CONFIG_LIB80211_CRYPT_CCMP=y
CONFIG_LIB80211_CRYPT_TKIP=y
CONFIG_HOSTAP=y
CONFIG_CRYPTO_MICHAEL_MIC=y
CONFIG_CRYPTO_MICHAEL_MIC=m
CONFIG_CFG80211_WEXT=y

View File

@ -1,6 +0,0 @@
CONFIG_PWM=y
CONFIG_PWM_SYSFS=y
CONFIG_PWM_OMAP_DMTIMER=y
CONFIG_PWM_TIECAP=y
CONFIG_PWM_TIEHRPWM=y
CONFIG_PWM_TIPWMSS=y

View File

@ -1,21 +0,0 @@
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += " \
file://rtl8192cu.cfg \
file://enable_pwm.cfg \
file://enable_onboard_leds.cfg \
file://enable_hostap_wext.cfg \
file://0003-bbb-enable-pwm.patch \
file://0002-onboard-led-init-disable.patch \
"
KERNEL_CONFIG_FRAGMENTS_append_ti33x = " \
${WORKDIR}/rtl8192cu.cfg \
${WORKDIR}/enable_pwm.cfg \
${WORKDIR}/enable_onboard_leds.cfg \
${WORKDIR}/enable_hostap_wext.cfg \
"

View File

@ -1,20 +1,17 @@
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += " \
file://rtl8192cu.cfg \
file://enable_pwm.cfg \
file://enable_onboard_leds.cfg \
file://enable_hostap_wext.cfg \
file://0003-bbb-enable-pwm.patch \
file://0002-onboard-led-init-disable.patch \
"
KERNEL_CONFIG_FRAGMENTS_append_ti33x = " \
${WORKDIR}/rtl8192cu.cfg \
${WORKDIR}/enable_pwm.cfg \
${WORKDIR}/enable_onboard_leds.cfg \
${WORKDIR}/enable_hostap_wext.cfg \
"

View File

@ -1,19 +0,0 @@
# This is the most basic ntp configuration file
# The driftfile must remain in a place specific to this
# machine - it records the machine specific clock error
driftfile /var/lib/ntp/drift
# This should be a server that is close (in IP terms)
# to the machine. Add other servers as required.
# Unless you un-comment the line below ntpd will sync
# only against the local system clock.
#
# server time.server.example.com
server 192.168.178.1
#
# Using local hardware clock as fallback
# Disable this when using ntpd -q -g -x as ntpdate or it will sync to itself
server 127.127.1.0
fudge 127.127.1.0 stratum 14
# Defining a default security setting
restrict default

View File

@ -1,2 +0,0 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"

View File

@ -1,9 +0,0 @@
#!/bin/bash
if [ -n "$1" ]; then
rsync -avz -e "ssh -o StrictHostKeyChecking=no" --progress tmp/deploy/ipk/ tkl@e320:/srv/ipk/$1
else
echo "Which branch?"
exit -1
fi

View File

@ -1,3 +0,0 @@
#!/bin/bash
rsync -avz -e "ssh -o StrictHostKeyChecking=no" --progress downloads/ tkl@e320:/srv/files/mirror/sources