kernel: add support for 4.12
Signed-off-by: Thomas Klaehn <tkl@blackfinn.de>
This commit is contained in:
parent
657e18387f
commit
d68af25483
45
recipes-kernel/linux/files/0003-bbb-enable-pwm.patch
Normal file
45
recipes-kernel/linux/files/0003-bbb-enable-pwm.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
diff --git a/arch/arm/boot/dts/am335x-boneblack-common.dtsi b/arch/arm/boot/dts/am335x-boneblack-common.dtsi
|
||||||
|
index 325daae40278..bd91b201bbf8 100644
|
||||||
|
--- a/arch/arm/boot/dts/am335x-boneblack-common.dtsi
|
||||||
|
+++ b/arch/arm/boot/dts/am335x-boneblack-common.dtsi
|
||||||
|
@@ -68,6 +68,40 @@
|
||||||
|
AM33XX_IOPAD(0x86c, PIN_OUTPUT_PULLDOWN | MUX_MODE7) /* gpmc_a11.GPIO1_27 */
|
||||||
|
>;
|
||||||
|
};
|
||||||
|
+
|
||||||
|
+ ehrpwm1_pins: pinmux_ehrpwm1a_pins {
|
||||||
|
+ pinctrl-single,pins = <
|
||||||
|
+ AM33XX_IOPAD(0x848, PIN_OUTPUT | MUX_MODE6) /* gpmc_a2.ehrpwm1a */
|
||||||
|
+ AM33XX_IOPAD(0x84c, PIN_OUTPUT | MUX_MODE6) /* gpmc_a3.ehrpwm1b */
|
||||||
|
+ >;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ ehrpwm2_pins: pinmux_ehrpwm2a_pins {
|
||||||
|
+ pinctrl-single,pins = <
|
||||||
|
+ AM33XX_IOPAD(0x820, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2a */
|
||||||
|
+ AM33XX_IOPAD(0x824, PIN_OUTPUT | MUX_MODE4) /* ehrpwm2b */
|
||||||
|
+ >;
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&epwmss1 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&epwmss2 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&ehrpwm1 {
|
||||||
|
+ status = "okay";
|
||||||
|
+ pinctrl-names = "default";
|
||||||
|
+ pinctrl-0 = <&ehrpwm1_pins>;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&ehrpwm2 {
|
||||||
|
+ status = "okay";
|
||||||
|
+ pinctrl-names = "default";
|
||||||
|
+ pinctrl-0 = <&ehrpwm2_pins>;
|
||||||
|
};
|
||||||
|
|
||||||
|
&lcdc {
|
17
recipes-kernel/linux/linux-yocto_4.12.bbappend
Normal file
17
recipes-kernel/linux/linux-yocto_4.12.bbappend
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
LICENSE = "GPLv2"
|
||||||
|
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
|
||||||
|
|
||||||
|
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
|
||||||
|
|
||||||
|
SRC_URI += " \
|
||||||
|
file://rtl8192cu.cfg \
|
||||||
|
file://enable_pwm.cfg \
|
||||||
|
file://enable_onboard_leds.cfg \
|
||||||
|
file://0003-bbb-enable-pwm.patch \
|
||||||
|
file://0002-onboard-led-init-disable.patch \
|
||||||
|
"
|
||||||
|
|
||||||
|
KERNEL_CONFIG_FRAGMENTS_append_ti33x = " \
|
||||||
|
${WORKDIR}/rtl8192cu.cfg \
|
||||||
|
${WORKDIR}/enable_pwm.cfg \
|
||||||
|
"
|
Loading…
Reference in New Issue
Block a user